Stalk issue!

Got a question about your ALPINA ask it here !
You've got the car now you need to know something, techincal advice, specific questions etc.

Moderators: Charles, neil, D4

Post Reply
gruppeb86
Posts: 8
Joined: Mon Apr 06, 2020 3:04 pm

Stalk issue!

Post by gruppeb86 » Thu Nov 19, 2020 6:31 pm

Hi all,

Seeking technical assistance with the following:

Car: Owner of a 07 Manual E90 D3 (Single Turbo).

Issue: Left side stalk is not functioning with respect of left/right indicator and main beam.
- Indicators do not function. Consequently, no tick tock or display on dash.
- Headlights can no longer be flashed and if pushed forward stalk will not hold position to allow main beam + no display.
- Computer functions from same stalk are perfectly fine.
- All other electronics are also fine.
- Low/High Beam functions correctly.
- Hazards function correctly too.

Car has been stood around as currently not in frequent use so start up was not perfect (normal for a diesel in cold conditions). Although I am sure this has no bearing on what could be a simple wear and tear problem due to age of vehicle.

The car is in very good order. Therefore borderline frustrated.

Is this a possible relay issue? Am concerned if plugged in, diagnostics may not give the answer.

Not prepared to waste money so as to line someone else's pocket!

Does it need a new stalk?

Any thoughts one and all?

User avatar
Charles
Moderator
Moderator
Posts: 7355
Joined: Mon Jun 23, 2003 2:44 am
Location: Oxford

Re: Stalk issue!

Post by Charles » Thu Nov 19, 2020 6:55 pm

gruppeb86 wrote:
Thu Nov 19, 2020 6:31 pm
Does it need a new stalk?
It sounds like the problem may be to do with where the stalk connects to the steering column binnacle as the functions that are not working are mechanical in their nature (i.e the stalk moves to a new position which triggers the function) whilst the electrical connections (i.e the computer controls) are working so the wires are sound.

To answer your question, it depends on whether the stalk and "base unit" come as one piece or two (the base unit being the part that the stalk fits into and allows the four way movement (up, down, forward and back).

It shouldn't be an expensive fix and probably something that any confident DIYer should be able to do.
Charles
Teacher of Chemistry and driver of ALPINAs - not necessarily in that order ;)
B3S Touring (49/116) - been to the moon and now on the way back!
Renault Grand Espace - not mine but the wife's!

gruppeb86
Posts: 8
Joined: Mon Apr 06, 2020 3:04 pm

Re: Stalk issue!

Post by gruppeb86 » Fri Nov 20, 2020 1:41 pm

Thanks Charles. Your final words fill me with some hope!

Local BMW dealer confirms the 'switch cluster' including indicator/wiper stalks is only supplied as 1 piece. Part number (specific to my vehicle) 61319123032 retailing at £413.88 + VAT. Total cost £496.66. Wow, then there's labour to add on top for the fix.

While ebay is an obvious purchase point, seemingly more reliable maybe www.schmiedmann.com. They offer a used replacement at £99.70 + Delivery from Denmark. Not ideal, most especially for a tip top Alpina.

Next step is committing to a garage and an honest/competent(!) mechanic. Am in no doubt my car could be sat their for days assuming the worst is to be accounted for. I really hope its something more simple as per your initial/logical thinking.

A bit peeved.

User avatar
Charles
Moderator
Moderator
Posts: 7355
Joined: Mon Jun 23, 2003 2:44 am
Location: Oxford

Re: Stalk issue!

Post by Charles » Fri Nov 20, 2020 3:00 pm

You might consider approaching a reputable BMW breaker to see if you can source the cluster at a significantly lower price.

I have had several good experiences with Quarry Motors but there are plenty of others out there and members here may have other recommendations.

A quick look at their website reveals that Quarry have two E9x 2007 models that they are currently breaking, so a quick phone call might be in order.
Charles
Teacher of Chemistry and driver of ALPINAs - not necessarily in that order ;)
B3S Touring (49/116) - been to the moon and now on the way back!
Renault Grand Espace - not mine but the wife's!

gruppeb86
Posts: 8
Joined: Mon Apr 06, 2020 3:04 pm

Re: Stalk issue!

Post by gruppeb86 » Fri Nov 20, 2020 4:59 pm

Cheers Charles. That's invaluable information.

I remain open to commentary from other members. You never know!

Considering a fault finding/diagnostic check from a mobile mechanic.

Maybe a fuse? I believe their could be one for the main beam (not the indicators).

It couldn't be the control module could it? That controls the engine right?

User avatar
Charles
Moderator
Moderator
Posts: 7355
Joined: Mon Jun 23, 2003 2:44 am
Location: Oxford

Re: Stalk issue!

Post by Charles » Fri Nov 20, 2020 5:21 pm

Reading your initial post, it sounds like the mechanical "lock" that holds the stalk up or down when indicating and the fixed headlight position are not holding which suggests a mechanical failure

However, the fact that the indicators and headlights are not functioning as well, suggests more - perhaps electical

But the computer control is working.

Might be worth paying the call out charge for a mobile mechanic to diagnose would be a good first step before committing to an expensive part if it isn't required.

Must admit, however, that in all my years on here, this is the first time I've heard of this. Have you had a look on E9x forums as this is a BMW issue, not an Alpina one? It does appear a number of times in other forums, so it looks like this is more common than you might have feared.
Charles
Teacher of Chemistry and driver of ALPINAs - not necessarily in that order ;)
B3S Touring (49/116) - been to the moon and now on the way back!
Renault Grand Espace - not mine but the wife's!

Post Reply